gfs2 file system · Supported
Maintainers
- M Andreas Gruenbacher <agruenba@redhat.com>
Paths
- F
Documentation/filesystems/gfs2/ - F
fs/gfs2/ - F
include/uapi/linux/gfs2_ondisk.h
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-mm (capped at 30), ordered by date desc.
-
STALE119d
REVIEWED: 1 (1M) [PATCH 02/42] gfs2: Don't zero i_private_data
2026-03-26 · Jan Kara <jack@suse.cz> -
STALE126d
REVIEWED: 1 (1M) [PATCH 02/41] gfs2: Don't zero i_private_data
2026-03-20 · Jan Kara <jack@suse.cz> -
STALE124d
[PATCH 40/53] gfs2: stop using d_add().
2026-03-12 · NeilBrown <hidden> -
STALE104d
[PATCH 10/61] gfs2: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE141d
[PATCH 11/32] gfs2: Don't zero i_private_data
2026-03-03 · Jan Kara <jack@suse.cz> -
STALE145d
[PATCH v2 3/4] folio_batch: Rename pagevec.h to folio_batch.h
2026-02-25 · Tal Zussman <hidden> -
STALE188d
[PATCH v2 26/31] gfs2: add EXPORT_OP_STABLE_HANDLES flag to export operations
2026-01-19 · Jeff Layton <jlayton@kernel.org> -
STALE188d
[PATCH 25/29] gfs2: add EXPORT_OP_STABLE_HANDLES flag to export operations
2026-01-15 · Jeff Layton <jlayton@kernel.org> -
STALE146d
[PATCH 24/24] fs: remove simple_nosetlease()
2026-01-08 · Jeff Layton <jlayton@kernel.org> -
STALE146d
[PATCH 10/24] gfs2: add a setlease file operation
2026-01-08 · Jeff Layton <jlayton@kernel.org> -
STALE238d
REVIEWED: 2 (2M) [PATCH RESEND v3] vfs: remove the excl argument from the ->create() inode_operation
2025-12-01 · Jeff Layton <jlayton@kernel.org> -
DORMANTno replies
REVIEWED: 1 (0M) [PATCH] gfs2: Prevent recursive memory reclaim
2025-11-13 · Andreas Gruenbacher <agruenba@redhat.com> -
DORMANTno replies
REVIEWED: 2 (2M) [PATCH v3] vfs: remove the excl argument from the ->create() inode_operation
2025-11-10 · Jeff Layton <jlayton@kernel.org> -
STALE261d
[PATCH v2] vfs: remove the excl argument from the ->create() inode_operation
2025-11-07 · Jeff Layton <jlayton@kernel.org> -
STALE264d
[PATCH] vfs: remove the excl argument from the ->create() inode_operation
2025-11-05 · Jeff Layton <jlayton@kernel.org> -
STALE260d
[PATCH v2 11/16] gfs2: add support in gfs2 to handle multiple writeback contexts
2025-10-14 · Kundan Kumar <hidden> -
STALE260d
[PATCH v2 01/16] writeback: add infra for parallel writeback
2025-10-14 · Kundan Kumar <hidden> -
STALE344d
[PATCH 01/11] mm: Introduce memdesc_flags_t
2025-08-05 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
STALE387d
[PATCH 11/13] gfs2: add support in gfs2 to handle multiple writeback contexts
2025-05-29 · Kundan Kumar <hidden> -
STALE387d
[PATCH 01/13] writeback: add infra for parallel writeback
2025-05-29 · Kundan Kumar <hidden> -
STALE443d
[RFC PATCH 2/7] treewide, slab: allow slab constructor to return an error
2025-04-24 · Harry Yoo <hidden> -
STALE470d
[PATCH v3 1/2] gfs2: replace sd_aspace with sd_inode
2025-04-12 · Andreas Gruenbacher <agruenba@redhat.com> -
STALE473d
[PATCH v2 1/2] gfs2: replace sd_aspace with sd_inode
2025-04-11 · Andreas Gruenbacher <agruenba@redhat.com> -
STALE475d
[RFC 1/2] gfs2: replace sd_aspace with sd_inode
2025-04-07 · Andreas Gruenbacher <agruenba@redhat.com> -
STALE483d
[PATCH] mm: Rename vm_area_struct to mm_area
2025-04-01 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
DORMANTno replies
[PATCH v3 6/6] mm/list_lru: Simplify the list_lru walk callback function
2024-11-04 · Kairui Song <hidden> -
STALE639d
[PATCH v2 6/6] mm/list_lru: Simplify the list_lru walk callback function
2024-09-25 · Kairui Song <hidden> -
STALE723d
[PATCH RFC 5/5] non-mm: discourage the usage of __GFP_NOFAIL and encourage GFP_NOFAIL
2024-07-24 · Barry Song <hidden> -
STALE701d
[PATCH 7/7] mm/list_lru: Simplify the list_lru walk callback function
2024-06-24 · Kairui Song <hidden> -
DORMANTno replies
[PATCH] gfs2: remove SLAB_MEM_SPREAD flag usage
2024-02-24 · chengming.zhou@linux.dev
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE146d
[PATCH 10/24] gfs2: add a setlease file operation
2026-01-08 · Jeff Layton <jlayton@kernel.org> -
STALE188d
[PATCH 25/29] gfs2: add EXPORT_OP_STABLE_HANDLES flag to export operations
2026-01-15 · Jeff Layton <jlayton@kernel.org> -
STALE188d
[PATCH v2 26/31] gfs2: add EXPORT_OP_STABLE_HANDLES flag to export operations
2026-01-19 · Jeff Layton <jlayton@kernel.org> -
STALE104d
[PATCH 10/61] gfs2: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE124d
[PATCH 40/53] gfs2: stop using d_add().
2026-03-12 · NeilBrown <hidden>